Introjucer module changes


#1

I've just spent some time (far longer than I anticipated!) on refactoring the way the Introjucer handles modules..

Previously, it had a concept of a "modules folder", where all the modules had to be stored, and you could set this folder for each exporter target. That was quite restrictive, and meant that you couldn't combine modules from different directories, so I've rewritten it to give each module its own path, and that path can be set differently in each exp

I've also rewritten the GUI so that the modules now appear in the config tree-view, and you can delete and add them from there - selecting the top-level of the modules tree shows a panel which lets you download and update modules from the website in a much more flexible way than before. You can also drag-and-drop module folders into the treeview to add them.

None of these changes should break any existing projects, but I've rewritten a huge amount of code, so please let me know if anything seems wrong! But please note that any .jucer files that get saved by this new version won't be backwards-compatible with previous introjucer versions.

The new structure gets it much closer to the goal of being able to offer automatic download/installation of 3rd-party modules, rather than just the juce ones.


#2

Hello,

I did not see anyone else on this forum have any similar issues with Introjucer so it is probably just me. I have upgraded Introjucer to the latest version (last commit from 2013-10-01 21:47:55) from the git repo and tried to open one of my projects. I can see JUCE modules listed in Config tab but when I click on any of them it just says "Cannot find this module at the specified path!". The module paths are correct (I even tried absolute ones). And also the entire Introjucer freezes for something around 10 seconds when I click any module. I also tried to create a new project and delete Introjucer configuration files, nothing helped. So, for now I stick with an older Introjucer revision which has no such issues.

My system is 64bit Debian GNU/Linux.

Best regards.


#3

Sorry - I hadn't got around to testing on linux. Have fixed it up now, let me know if you have any more trouble with it!


#4

Hi Jules,

 

Can you add a proxy configuration option to download modules ?

 

Thx
 


#5

What do you mean?


#6

I'm working thru a authentified proxy, so when i click on the button "Download and add a module", the connection failed...

If i can configure a proxy and login/password for the connection, the download work :)

 

PS: A little bug: When i want to delete a module (rigth click), IntroJucer crash !

 


#7

Surely that kind of thing is a job for your OS's network setup? It'd be crazy to expect all apps that want to access the internet to each provide their own way to specify a proxy..

Deleting modules works fine here in OSX, maybe another linux thing? I'll check when I get a moment.


#8

No.. deleting modules also works for me in linux. You'll need to give me more details about that if there's a problem.


#9

Everything seems to be working properly now.

Thank you very much.