JUCE 4.3.0 plugins won't compile on OSX 10.7.5


#1

Using JUCE 4.3.0, for some reason I’m not able to get AAX to run on PT10 OSX 10.7.5. This was built on another machine, 10.10.

Looking for the problem and a fix, I’m trying to build JUCE on the said 10.7.5 machine, with XCode 4.3, but this throws the following errors:

Semantic Issue
No matching function for call to 'layoutListToArray'
No matching constuctor for initialization of 'juce::AudioProcessor'

Files are juce_AudioProcessor.h and juce_AudioPluginInstance.h respectively.

I tried all compiler and language dialect combinations, but this doesn’t affect it.

I’m quite a latecomer to the OSX development on anything older than 10.9. Are there some quirks that I should/could know of, or is this just deprecated stuff?

Thanks!
Olli


#2

I would suggest using a modern Xcode to compile for older OS X versions - with the latest Xcode version you can set the deployment target down to 10.5 in the Projucer and it will work if do the same when compiling the AAX libs (caveat: I’ve never tried to go this old with the AAX libs, there may be more issues there that I’m not aware of, and the AAX format itself is fairly recent compared to other plug-in types).

C++11 compiler features are being currently being introduced into JUCE so ultimately you’ll have to use a modern Xcode if you want to keep up with JUCE development.


#3

Thank you for your insight t0m!
Yeah I reckon this is what I’m going to go with, I rather go with the C++11 features and see from there.


#4

If you’re going to use C++11 features and target older versions of OS X then you should also beware that compiler features will be supported (auto, range-based for, …) but standard library features (std::function, std::mutex, …) may be unavailable.