Minimum OS X version


#1

What’s the minimum OS X version that’s officially supported? Both the “hello world” sample and the JUCE demo crash on my 10.2 system. Works fine on 10.3 and 10.4.

Requiring 10.3 or better is fine for my purposes; I’m just curious.

Thanks,

Matt


#2

Depends how you compile it - I don’t think there’s any code in Juce that won’t run on 10.2, but if you’re using a later version of XCode I don’t think it produces backwards-compatible code unless you tell it to.


#3

I had built the JUCE library and the apps with “Mac OS X Deployment Target” set to 10.2. I’m using GCC 4; maybe I need to back off to 3.1 or something.

The stack dump is similar for both:

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe0323c in load_library_image
#2 0x8fe060d4 in load_images_libraries
#3 0x8fe02688 in load_executable_image
#4 0x8fe013b0 in _dyld_init

So that suggests that the crash is happening before the app runs.

Anyhow, this is no big deal. I’m sure it can be solved if it becomes pressing. Requiring 10.3 is fine.

Thanks for getting back to me-

Matt


#4

Never mind - I failed to RTFM. You have to build with GCC 3 if you are running on anything before 10.3.9. Works great now.

So I can build on 10.4 using Xcode 2.1 and still run on 10.2. Very cool.

JUCE is very nifty, by the way.

Matt


#5