Juce module has a question mark beside it, can't be updated


#1

I feel as if I already asked this - but can't find it?

For some reason, one of my Juce modules now has a question mark beside it.  It might be that that was where I made a test change to fix the UTF-8 issue (that's now fixed in Juce) - though I thought I'd reverted this before updating.

Unfortunately, this means that I can't update that module any more - because the update is also disabled for that module!

If the Introjucer can't identify which version it has of a module, that's no reason to disable updating for that module - quite the reverse, if I've made some change, whether on purpose or by accident, to that module, one of the most common things I'll want to do is to revert to the "official" version.

I'm not quite sure how to remedy this - thinking of just copying in the files from the main "Juce" repo which I also have around...


#2

Since I changed it to allow you to set your own path for each module, that probably just means that it can't find whatever path is specified for that module. But if all you want to do is to update it, you should be able to just remove it and use the "download and add a module" button to re-download it again.


#3

Unfortunately, this doesn't work (I tried it before I posted last time, should have mentioned, just tried it again to confirm).

When you do that, the module (juce_gui_audio) gets deleted all right - but then the pulldown menu for adding modules does not contain it.

I restarted The Introjucer again.  It still doesn't allow me to add that missing module - but worse, a new module (juce_events) is now marked with a ?.  

Now, when I delete that, I can actually re-add it, and now it doesn't have the question mark - BUT juce_gui_audio is back, and it has that question mark again!


#4

I don't think "juce_gui_audio" is actually a JUCE module, it's not in the tip. Perhaps there's an old index or cache with that name around somewhere so it's looking for it but can't find it. Does it cause compilation problems? Presumably nothing is referencing it?

You could try editing the Introjucer project file manually and removing it.


#5

Ah, yes, that juce_gui_audio thing was actually caused by a typo in the old introjucer, which would add it to the modules list when you create a new project, but in fact there's no such module! The old version's module list only displayed modules which existed, so it would never appear on screen, but the new version attempts to show everything that the project contains.

Just select it in the list and hit 'delete'!


#6

No wonder everything compiled either way!  :-D

What's funny is that I have a rec::gui::audio namespace (I'm "rec") so it seemed really logical to me.