JUCE not finding VST files that are there

So JUCE is giving me errors that I don’t have aeffectx.h (which was there), so I disabled VST and only enabled VST3. Now it’s telling me that it can’t find baseiids.cpp, but I can clearly see that it is the VST3 folder. Any idea why this would be occurring?

The only thing I can think is to check your global preferences are set to the correct locations for each of the SDKs

experienced the same issue, was brushed off as non existent, build still broken

What does this mean lol

Well, if it can’t find an included file, then your include path is wrong… How could we help you other than saying “give it the correct include paths”? There are specific places in the Projucer for setting these paths for VST2 and 3.

Certainly not brushed off as nonexistent (see my post here). If VST compilation is really broken that’d be a very worrying bug. It’s just highly unlikely because none of us can reproduce it here. In 99.9% of the cases it’s because any of those:

  • the VST SDK path is wrong in the Projucer’s global preferences
  • the VST SDK path is wrong in the Projucer’s Xcode exporter preferences for your project
  • you don’t have the correct version of the VST SDK (the one to use is 3.6.5 from http://www.steinberg.net/en/company/developers.html for both VST2 and VST3)
  • your VST SDK may be somehow corrupted or not contain the file you try to include
  • you didn’t re-save your project from the Projucer so it still has some wrong paths
  • something specific to your project, therefore please also test it with the JuceDemoPlugin (JUCE/examples/audio plugin demo)

Let me illustrate this in a screenshot:


I’m guessing he’s using Visual Studio. The default paths for the VS Exporter is set to Mac path style. Just change to Windows path style.



I’m using a mac lol

I appreciate this diagram but this is exactly how I have it set up an it still isn’t working

Are you sure that you also have tried it with the JuceDemoPlugin and that this project also doesn’t work? And have you checked that the header affectx.h you are trying to include is actually there?

Can you please also check if the include paths have been set in Xcode correctly?

Hey guys,

I’m getting this same error, paths are OK, files are there, tried quitting and opening the Projucer again, setting the paths in Xcode, with no luck.

Any ideas?

Xcode Version 8.0 (8A218a)
El Capitan 10.11.6 (15G31)
Projucer 4.2.4

Hi again, so I managed to make it work. Since I use Dropbox a lot, i had my SDK in a folder in my Dropbox, so now instead I made a copy of it at /Users/MYUSER/SDK/ and et voila, it works! Hopefully that might be of some help to someone!

Hi, I had the same problem, not being able to compile because VST3 SDK wasn’t found, even with all the paths and parameters correctly set, I solve it though, by making the header search path recursive.

'~/SDKs/VST3 SDK/**' instead of '~/SDKs/VST3 SDK'

In Windows I had to change it from “C:\SDKs\VST3_SDK” to “C:\SDKs\VST3_SDK”, save in pro jucer, re-open visual studio.

What’s “still broken”?

The intention is that you should set the path to wherever the SDK lives on your own machine - we can’t possibly ship the project with a built-in path that is correct for everyone. (Perhaps our mistake here is to have put an example path in there rather than leaving it blank…)

Wow… two years before somebody mentions that there is a script in the VST3_SDK to copy the VST2_SDK into the VST3_SDK folder. But it’s not like anybody tells you that you need to move VST2 - unless you check the readme file:

Adding VST2 version

In order to build a VST2 version of the Plug-in and a VST3 at the same time, you need to copy the VST2 folder into the VST3 folder, simply run the following commands:

  • for macOS:
cd TheFolderWhereYouDownloadTheSDK
  • for Windows:
cd TheFolderWhereYouDownloadTheSDK

So, people were correct that they could specify the VST3_SDK folder and still not have all of the associated files found. Of course, Steinberg could have just distributed it that way, but it’s our fault for still liking the legacy format they prefer to leave behind.

In my case, the issue seemed to be using the provided ~/ rather than Users/username/ path prefix, for XCode.