Latest trunk - Visual Studio Error - 'Movies.h' No such file


#1

Just checked out the latest juce trunk and got an error while building my project.

and


#2

Ok, got it.
So now we have to have the QuickTime SDK installed.

This is how I got it all working in VS2005:

JUCE.vcproj has to have the path e.g. “\QuickTime SDK\CIncludes” in the Additional Include Directories, or in juce_quicktimeaudioformat.cpp and juce_quicktimemoviecomponent.cpp #include Directive for Movies.h.

Also the project that your working on i.e. yourApp.vcproj or juce_application.vcproj, has to have the path e.g. “\QuickTime SDK\Libraries” added to the Linker Additional Library Directories.


#3

Oh yes I almost forgot, before all that you have to download and install QuickTime SDK if you haven’t already done so.

You cant just get away by having iTunes or QuickTime installed on your Windows machine anymore if your planning to use the latest trunk of juce.


#4

In a release build, I’d normally leave the quicktime stuff turned off in the juce_Config file - you can do that too if you don’t want to install the SDK.

I’ll add a comment to that include line anyway, to explain this when people hit that error.


#5

true.


#6

Sorry for reviving this old thread.
This may seem obvious to most, but i’m still pretty noob, & i couldn’t follow most of what aiit was saying. :cry:

Basically, I ran into the same prob as aiit with the missing movies.h header file.

So I open the juce_Config.h file, to find the quicktime bit already commented out.
#if ! (defined (JUCE_QUICKTIME) || defined (LINUX) || (defined (_WIN32) && ! defined (_MSC_VER)))
//#define JUCE_QUICKTIME 1
#endif

I tried masking off juce_amalgamated.cpp’s references to quicktime too, but it didnt work either.

So I decided that installing the Quicktime SDK wmightn’t be too much of a pain,

but I’m still getting the error about the missing movies.h file.

Would really appreciate any help fr anyone…
Thanx guys!
Paul C


#7

Are you starting from scratch or are you building on top of
…\example projects\example_project_for_Win32 ?

If you’re using the example project then check juce_AppConfig.h

[code]/*
This file contains settings that you might want to explicitly apply to
the your build.

Most of these are turned on or off by default, but you can override
that setting here by un-commenting it and giving it a 1 or 0 value.

*/

//#define JUCE_ONLY_BUILD_CORE_LIBRARY 1
//#define JUCE_QUICKTIME 0
//#define JUCE_FORCE_DEBUG 1
//#define JUCE_LOG_ASSERTIONS 1
//#define JUCE_ASIO 1
//#define JUCE_ALSA 1
//#define JUCE_QUICKTIME 1
//#define JUCE_OPENGL 1
//#define JUCE_USE_FLAC 1
//#define JUCE_USE_OGGVORBIS 1
//#define JUCE_USE_CDBURNER 1
//#define JUCE_ENABLE_REPAINT_DEBUGGING 1
//#define JUCE_USE_XINERAMA 1
//#define JUCE_USE_XSHM 1
//#define JUCE_PLUGINHOST_VST 1
//#define JUCE_PLUGINHOST_AU 1
//#define JUCE_CHECK_MEMORY_LEAKS 1
//#define JUCE_CATCH_UNHANDLED_EXCEPTIONS 1
//#define JUCE_STRINGS_ARE_UNICODE 1[/code]

But if I remember correctly this should do it.

[code]//=============================================================================
/** Comment out this macro if you don’t want to enable QuickTime or if you don’t
have the SDK installed.

If this flag is not enabled, the QuickTimeMovieComponent and QuickTimeAudioFormat
classes will be unavailable.

On Windows, if you enable this, you'll need to have the QuickTime SDK
installed, and its header files will need to be on your include path.

*/
#if ! (defined (JUCE_QUICKTIME) || defined (LINUX) || (defined (_WIN32) && ! defined (_MSC_VER)))
// #define JUCE_QUICKTIME 1
#endif
[/code]


#8

Let me know how it works out for you. If you still having problems post some more info on how you’re trying to build JUCE i.e. if you using the JUCE example project provided with the JUCE library. If you’re using the amalgamated version of JUCE etc.


#9

thanx for the quick reply, aiit!

i’ve just started out n am new to both msVC & Juce have been tring both building Jule’s demos & from scratch using Haydxn’s Starting Point Guide…

both codes u’ve quoted have already been commented out as u’ve shown when i’d first downloaded version 1_46…

hmmm… it’s working now - i’ve found that i actually needed to uncomment the quicktime line in juce_AppConfig.h & set it to 0:

ugghhh… The next error is with a missing iasiodrv.h
i don’t think i’d like to disable asio, i suppose i need to install the asio driver on my puter? - let me try that & post back

Thanx again, aiit! :wink:


#10

lessee, what I needed was to point VC to where to look for include & library files…

This is if u need to include ASIO/Quicktime/etc

I’ve posted these instructions here:
http://www.rawmaterialsoftware.com/juceforum/viewtopic.php?p=18683#18683

Thanx aiit n all!


#11

Thanks boogiebehometh for your last 2 tips! these worked for me! I wonder, why I have to uncomment explicitly "#define JUCE_QUICKTIME 0 ", even if I´ve already uncommented the macro in “juce_Config”-file, like jules wrote…

anyway, it works fine now!


#12

glad it was of help, pooz :wink: