Mac Introjucer build


#1

I’ve built the Introjucer on the mac (pc guy trying to port to mac). It’s built but spits the Introjucer to some long obscure path. I’m used to visual studio creating a build folder debug/release right at the root of where it was built from.

When I try to mv the Introjucer to a location one level next to where I’ve installed JUCE when I run I’m getting an error saying unable to load recent files.

Should I just run the Introjucer from the spot where xcode has placed it? Is there some xcode settings that I can spit out the Introjucer to a location I desire and still have it run?

Thanks

ps This is day 2 of this headache. I know its me being a new lad in Mac world.


#2

I just run the Introjucer from where it resides.

However, it runs but when I got to open the myproj.jucer (moved over from PC) file in the IntroJucer it is greyed out and I cannot select it.

What have I done wrong?

  • used git to get the latest JUCE
  • built the IntroJucer
  • placed my project folder that I had on PC to Mac.
  • Run Introjucer but *.jucer file is greyed out.

#3

Appending to my earlier post…all files are greyed out. Only directories are selectable.


#4

Are you using the existing Introjucer Xcode project file that comes with juce?


#5

I believe so. I went into the IntroJucer folder to the builds/Mac OSX and built the Introjucer.xcodeproj.

It built fine. The Introjucer was spit out to /users/demo/library/developer/xcode/deriveddata/The_Introjucer-blahblahblah/build/products/debug/Introjucer.app/contents/MacOS

I just run it from there using ./Introjucer.

It comes up when I go to file open the .jucer file is greyed out.


#6

Fixed now.


#7

Is that a question asking if it is fixed? Or is that saying it is fixed and I should grab list git and rebuild?


#8

I’ve fixed it, get the latest version.


#9

Okay…thanks!


#10

Well, I’m new to Macs so don’t know what is going on now. When I try to run git I’m getting “permission denied” error. It worked for me hours ago.

Did the ssh key change?


#11

Never mind. It is working now.


#12

The IntroJucer is working. Thanks Jules. However, when I change the “Local JUCE Folder” to the path where JUCE is installed on the Mac. When I save the project and open in xcode it fails because it is still looking for the path set for the PC.

I’ll get on my PC and change it there and put on Mac and see what happens.


#13

I read an earlier posting. I had to change the project settings to explicitly use the 10.7 OSx.