Missing header file?


#1

So whenever i run the audio host plug in example i get this message

I dont know why this is and have tried setting the path etc, but doesnt seem to work, can someone please help.

I’m running mavericks currently 10.9.5


#2

Just recently juce had to adapt to changes for the new VST SDK 3.6.7. So if you run the latest juce development version, you should update your VST SDK to 3.6.7 or (newer if someone reads in the future…)
If you run an older version of juce you might have to downgrade your VST SDK to 3.6.5 IIRC.
That might solve your problem.
Good luck
P.S.: don’t overwrite but backup your old SDK, in case something goes wrong or if you have to run an old juce version later on…


#3

Thank you, I have indeed done this, as I have only installed last week so is all the latest versions but still get that message, is it part of the older sdk library do you think? It’s frustrating because it won’t allow me to run the earliest examples in the tutorials so im not making any progress. Thanks again


#4

All the demos were created using the old SDK – if they have a .jucer file you should be able to open that in ProJucer and save it to generate a new exported version which will use the latest JUCE and SDK… or use the old VST SDK

Rail