Out-of-the-box audio plug-in created with Projucer doesn't load


#1

I have just created from scratch an audio plug-in project using Projucer from the latest JUCE.

I only enabled VST and VST3 formats, and the path for the VST SDK is correctly set in Projucer.

The project opens and builds fine in Xcode 7.2, but the resulting plug-ins aren’t recognized (i.e. they are not listed) in any host I could open (tried with REAPER, Cubase and Live)

The plug-in project is “vanilla”, i.e. it is exactly the project as it is generated out of the box from Projucer, I didn’t add anything to it yet.

I am developing plug-ins with JUCE since long before Introjucer was even conceived, and I don’t like the tool very much. I am resorting to it in the hope to quickly test whether a problem I’m seeing with audio channels in my “real” plug-ins, also happen with a bare minimum plug-in generated with Projucer. Unfortunately, this is taking way more time than expected.

Is there anything obvious that I am missing here? These are the exact steps I am taking:

  1. Build and start Projucer
  2. Create with Projucer a new Audio Plug-in Project
  3. Choose a name and a folder for the project
  4. Enter the path for the VST SDK
  5. Enable VST and VST3 formats, disable all others
  6. Save the project and open it in the IDE (Xcode 7.2)
  7. Build the aggregate target “MyPluginName (All)”

The build goes fine and I see that the .vst and .vst3 files being generated in the Library/Audio/Plug-ins/VST and Library/Audio/Plug-ins/VST3 folders in my home.

Despite that, They don’t get listed in any host I have tested (REAPER, Cubase and Live), even after forcing a plug-in rescan.

I have tried this same procedure both with the master branch and the develop branch. Same result.


#2

Does the bit size match the host?

Rail


#3

Are you on OS X <= 10.10? For reasons only known to apple, if you use the default deployment target in Xcode 7, it will default to 10.11, i.e. the default setting will create a binary that will not run on your own machine. You will need to change the “OSX deployment target” setting in the Projucer.


#4

Ah… yes, I am using 10.10 indeed.
Thanks for pointing that out, I will try that as soon as possible but by the sound of it I think that was the culprit.

Maybe in Projucer you could add a warning message when one is saving a project on OS X 10.10 with the default deployment target? that’d be to prevent others from having my same problem in the future


#5

I’m trying to work out a similar issue.

By default the VST Binary File LOcation is set to :
($HOME)/Library/Audio/Plug-Ins/VST

On my system this goes by default to Singular/Users/Meu/Library/Audio/Plug-Ins/VST

My actual VST Systems folder is Singular/Library/Audio/Plug-Ins/VST.

If i write out this path in the Projucer - it creates a new Library Folder in Singular with the entire subfolder heirarchy ->Library/Audio/Plug-Ins/VST.

Can someone help me out with this? A Library folder already exists in this drive - why is a new one being created? Also, directly copy pasting the /vst file into the right folder doesnt work.

Cheers,
Vishal