Problems with compiling JUCE files n Xcode


#1

I have a simple JUCE project that when compiled in Xcode give an error that FLT_MAX is an unidentified operation. I did not use FLT_MAX or anything from the header file to which it belongs anywhere in my program. I heard this may have something to do with JUCE libraries overwriting or writing out OS10.12 frameworks. If you think you can help i would be more than willing to send u my project for inspection. Thanks!


#2

Have you tried setting JUCE_USE_FLAC to disabled in the juce_audio_formats module in the Projucer like this post suggests?

Ed


#3

I tried that too, yes.


#4

Ok. Can you send me your code to take a look at?

Ed


#5

https://drive.google.com/drive/folders/0B75k76WXZFEzSDJYcjN1aVI2Y2M?usp=sharing (let me know if theres any problems accessing the files)


#6

Thanks, it compiles fine for me using Xcode 8.1 on my machine running macOS Sierra 10.12.1. I’m pretty sure we don’t use FLT_MAX anywhere in JUCE so the problem must be something on your end.

Sorry I can’t be of any more help!
Ed


#7

aw man :frowning: just in case I’m messing up the processes somehow, could u describe ur compiling process (i know it seems like a lame question)


#8

Sure! I opened the .jucer file from your project after downloading it, set the file paths of the modules to my JUCE/modules directory in the Projucer and then saved and opened the project in Xcode. I didn’t change any of your code and just built and ran the project from within Xcode and it worked fine. Is your Xcode is up to date?

Ed


#9

my xcode is. I am runnign 10.12.0 right now. i will try that update