Problems with JuceDemo and StartingPoint(Tutorial)


#1

Hi there
I’m new to Juce…
Curently I’m using VC++ 6. I installed the latest Platform SDK from Microsoft. And I compiled the Juce .lib files as it’s written in the Juce Readme File.

But if compile (I get no errors) the JuceDemo and try to run it I get a Message of VC++ that says: “Please specify the executable file”.
I thoght the demo will compile the same .exe file as the one on the Juce-Homepage.

My second problem is this compiling-errormessage, when compiling the StartingPoint files from haydxn:

d:\eigene dateien\c++ libraries\startingpoint\applicationstartup.cpp(55) : error C2664: '__thiscall juce::DialogWindow::juce::DialogWindow(const class juce::DialogWindow &)' : cannot convert parameter 1 from 'const class juce::String' to 'const clas s juce::DialogWindow &' Reason: cannot convert from 'const class juce::String' to 'const class juce::DialogWindow' No constructor could take the source type, or constructor overload resolution was ambiguous Error executing cl.exe.

I hope someone can give me some advice…
thx
Luke


#2

yeah, juce has been changed a bit since those starting point files, go to juce.haydxn.net and get the new files from the tutorial section. it’s up to date with the latest release


#3

sory I didn’t recogize that there is a newer version of the tutorial-files.
But I still get an error. This time a linker-error:

LINK : warning LNK4098: defaultlib "LIBCMTD" conflicts with use of other libs; use /NODEFAULTLIB:library uuid.lib(objidl_i.obj) : fatal error LNK1103: debugging information corrupt; recompile module Error executing link.exe.v
Suppose it has to do with the linker settings.

btw: Thanks a lot for the tutorial haydxn! I’t seems to be a great thing (even it’s not working yet for me).


#4

That error is a microsoft glitch - some of the older microsoft compilers won’t build with the newer microsoft libraries. If you’re on VC6 you need to make sure that VC6’s old libraries are before the platform SDK libs in your search path.


#5

OK thanks!
It compiles so far…
But I still get a warning after compiling and linking:

[code]Compiling…
ApplicationStartup.cpp
JUCE! Linking to: jucelib_static_debug.lib
MainAppWindow.cpp
JUCE! Linking to: jucelib_static_debug.lib
Linking…
LINK : warning LNK4098: defaultlib “LIBCMTD” conflicts with use of other libs; use /NODEFAULTLIB:library

JuceStartingPoint.exe - 0 error(s), 1 warning(s)[/code]
If I build the application again the warning disapears…

But the real problem I’ve got is a runtime error:
If I try to run the .exe-file I get this message-window:

"Debug Error!

Program: …\Debug\JuceStartingPoint.exe

R6016

  • not enough space for thread data

(Press retry to debug the application)"

Probably I should install VC++ express and try again… but I don’t like the idea of beeing forced to install the .net framework.

I hope I don’t bother you with my newbee questions…

Thanks a lot for your help!

Cheers Luke


#6

Under Tools|Options|Directories, your “Include files” should look something like this:

C:\MSSDK\INCLUDE
C:\VC98\INCLUDE
C:\VC98\MFC\INCLUDE
C:\VC98\ATL\INCLUDE
C:\JUCE

and your “Library files” should look something like:

C:\MSSDK\LIB
C:\VC98\LIB
C:\VC98\MFC\LIB
C:\JUCE\BIN

Then in your project settings, under Link, select the category “Input”, add to the box “Ignore libraries:” (for the Debug version):

libcd,libcpd

(and for the Release version):

libc,libcp

That will allow you to compile, link, and run without any errors.

  • kbj

#7

Thanks guys!
Now it’s working :smiley:

Had error with linking uuid.lib. But I renamed the file in …\Platform SDK\Lib and hoped VC++ would compile a new one. But VC++ didn’t add a new one to the Lib folder. :?:

Anyway… the project compiled with no error… and the .exe is running without runtime error!

again: thanks a lot guys! You’re great!!!

Luke

…be prepared for new questions… because now starts the coding… :smiley:


#8