Producer Hangs at start-up

projucer
windows

#1

I built Projucer on a Win10 tablet I haven’t used in about a year (MSVS2017 Community) - develop branch and tried to run it, but it hangs (exception in juce::ActiveXControlComponent::createControl(const void *)
400: {
401: // the component must have already been added to a real window when you call this!
402: jassertfalse;)

I then built Demo and that worked fine.

So I wondered if he crash was related to the fact I’d never registered Projucer before on that machine, so on another PC (Win 7, where Juce has been happy for a very long while… ) I logged Projucer out of my account, restarted and re-ran Projucer… and hit the same exception :frowning:

I thought I’d seen something about this in an earlier post (recently), but couldn’t find it.

Seems Easy to recreate… Log out of your account and run Projucer (or run Projucer on virgin machine… which, IMHO, is a worry for newbie-uptake)


#2

Thanks for the report, there will be a fix on develop shortly.


#3

Thanks! Fixed