Starting Projucer for the first time -- Can't log in

I’m totally new to JUCE, and I’m starting up Projucer for the first time, and I can’t get past the login. I just created and activated a new account, but I get this when I try to log in:


If I type in an intentionally wrong password, I see an “invalid password” error. I only get this when I type in the correct password.

This is on Windows 10, with a fresh download and unzip of JUCE 5.4.7.

Please help.

I’m having the same issue…
I’ve tried:

  • using the prebuilt Projucer exe
  • Building a Debug and Release build from the develop branch
  • Building a Debug and Release build from the juce6 branch
  • Building a Debug and Release build from the master branch

The juce6 branch is working for logins but it won’t build a template plugin after you create a project…

Please look here, I posted a solution in this thread:

Thanks for the advice, but this only seems like a partial workaround.

I’d like to release my plugin under the Personal license, not the GPL license. From what I can tell, using this workaround will prevent me from doing that.

So you probably have to wait for JUCE 6 or try to use the current version on another machine where this problem is not present (IIRC it was caused by an old version of the IE plugin).

From what I can tell, the script is caused by a change on the JUCE website itself, and there’s no easy fix from the application side. I’m guessing this will happen to anybody on windows regardless of any installed component version or registry hack to get the WebBrowser ActiveX component to use different document models.

This is the offending line:
const params = new URLSearchParams(

As you can see on, URLSearchParams is not supported on any version of Internet Explorer, so even if you could upgrade the ActiveX control somehow, it’s not going to help.

The only way to fix this from the application side would be to port the login window to the WebView2 ActiveX component which uses Microsoft Edge, but that would be a lot of unnecessary work. The simplest solution here by far would be for JUCE to change that line of javascript on their site.

You can easily replicate this in a browser by going to the errant URL manually:

We’ve removed the web view sign-in process from the Projucer in JUCE 6. There is also support for the more modern, chromium-based WebView2 in the WebBrowserComponent which should resolve issues with old IE-based web views.

Can you be more specific? We haven’t had any reports of issues with project creation on the JUCE 6 branch.

I’m also having the same issue after moving to a new pc, previously had no problems with 5.4.7.

Interestingly, although I can still login via browser without issue, I’m not receiving any emails when trying to reset my password or when changing the email associated with my account. Not sure if that is related at all.

edit: the issue with emails seems to have resolved itself

I can’t remember exactly what did it, but it was an issue on my end. Sorry for the worry! I got all the way through the first tutorial now and made a midi volume control.

We’ve just pushed an update to the javascript in the Projucer webview. Please let us know if it’s still not working.

Seems to be fixed now, no more issues here at least. Thanks!

Thanks for the quick response. Works here now too.