The Projucer first time logging in error

I am getting an error while running Projucer first time, it looks like this:
When I click Yes (in Polish: Tak), write credentials and click Sign In, it gives me similar error. Then I click Yes (again), and it gives me sign in form again.
I saw one topic about this error, but that did not help me. Sorry for my English :wink:
Steps to reproduce this bug:

  1. Unzip JUCE
  2. Run Projucer.exe
  3. If script error message occured, click Yes
  4. Give credentials
  5. Click Sign In
  6. If script error message occured, click Yes (again)
  7. And now we have “while (true)” loop from step 4 to this step :smiley:

OS: Windows 8.1
IE version (I think it can be fault of IE): 11.0.9600.19431, 11.0.140
JUCE version: 5.4.4

I am not a windows person, but I saw this topic a few times (Forum search :wink: ):

@daniel Does JUCE have a Makefile? Or do I have to use “gcc juce_file1.cpp juce_file2.cpp…”? Or do you know any other way to compile JUCE? I am completely new in JUCE and these subjects… thanks in advance :slight_smile:

You mean the projects generated using the Projucer?
On the left side, there is the “Exporters” section, usually a default depending on your platform is already present. By clicking on the “plus” button you can add other project formats, like XCode, VisualStudio2019, LinuxMakefile etc.

You will find those files in the folder “MyProject\Builds\VisualStudio2019\MyProject.sln”

Hope that helps

Hi @Pierniczek,

Welcome to JUCE forum.

I was not able to replicate this error on my Win 8.1, but I got IE 11.0.9600.188, 11.0.50. So I have updated my system. My current IE is 11.0.9600.19463, 11.0.145. And now I got the same error :slight_smile: And I cannot login to Projucer :frowning:

I will try tomorrow to find something more.
For now I found only this thread:
Probably something for JUCE team to adopt js to IE11, but I am not sure.

Greetings from Łódź :smiley:

There is a workaround: you have to build Projucer with #define JUCER_ENABLE_GPL_MODE 1.
So just find AppConfig.h file in JUCE\extras\Projucer\JuceLibraryCode, change this define, go to ‘Builds’ folder and you will find VisualStudio project in VisualStudio2015 folder. Open it in Visual Studio, build (as release) and you will have your version of Projucer with the login option off.

By the way, on some Linux distributions I have never got it working too, I hope some day this web browser interface will be replaced by standard Juce components, I think it was discussed some time ago on the forum.



After removing update KB4516067 I am able to login again to the Projucer. So it could be another workaround.


@daniel @MBO So, if I understood, you mean that I need to have project to compile JUCE, right? If so, can I use example project to do this?
@mateusz How to remove update? I know that it can be a noob question, but I really do not know :laughing:
Greetings from some-village-in-Subcarpathian-voivodeship :smiley:

You need to compile Projucer project which you can find in JUCE/extras/Projucer/Builds/VisualStudio2015 for example.

@MBO ok, sorry, I overlooked that :laughing:
Problem solved

Good to hear that the problem is solved (via workaround :p).
Just to answer a question about removing windows updates, here is a good instruction:
(It is not a noob question)

Have fun with JUCE and ask as many noob question as you need :smiley: