Projucer 5.0.0 cannot update to 5.0.1 on Windows?


#1

Hi,
Projucer tried to update itself, worked properly on MacOS, but on Windows, it can’t. Is it expected or a known bug that has a known workaround?


#2

I have had this same problem on Win764, where it downloads all but then says cannot overwrite the install folder. I just have it in c:/JUCE.

Initially I thought it was due to a file explorer being open but I made sure to close everything and it still does not want to complete the update.


#3

Yes, same here. I did not try with the new JUCE 5.0, but had similar problems on the older JUCE versions. Using Win 7 64-Bit.

But you can just “re-install” the new JUCE version. Or actually, it is not installing, just unzipping. I.e. rename the old JUCE folder to something like “JUCE_old”. Then unzip the new version and put it in the place of the old one.


#4

Yes, exactly. I was just piping in that there is a problem with some permissions or something, because it seems to download and extract correctly, it’s just right at the end it fails.


#5

Can the installer write to C:\ without admin permissions? Did you try running as admin?


#6

Well, I didn’t try this but I have had other installers extract sdks right to my C drive without running as admin and the operation worked correctly.

(I will try it)


#7

Ran as admin, same problem at the end, so there is something else amiss.


#8

long-shot I guess, but always a good test to get out of the way…


#9

I don’t have it on C, so I knew it wasn’t that.