Projucer Trial Version Sign In


#1

Hi,

I have installed projucer. But I am not able to sign in. The option for Sign-in is disabled in Projucer.

How should I Sign In to start using projucer?

Thanks in advance.


#2

Sign-in isn’t needed (and won’t appear) unless you’ve got the live-coding DLL, because the compiler is the only thing that you need to sign-in to enable.


#3

Thanks for reply.

As per my knowledge, Access full projucer access is allowed for one month in trial version.

How will I be able to use it fully? Many tabs are disabled in Projucer. I think they will be enabled once i sign-in.

Please correct me if i am wrong.


#4

Not really, there’s only one tab disabled, which is the build tab. Once you’re signed in, that’ll start working.


#5

HI,

I have attached snapshot of projucer window. Edit and GUI Editor are also disabled.


#6

It’s not very intuitive IMHO, but as soon an you know it, it seems obious in the first place…

Change to the Files tab (not in the menu but in the Project view (Files - Config - Build)
And with right click use the wizzard to "Add new GUI Component…"
If you select then the cpp file you will see the GUI editor and all menu items are no longer greyed out…
HTH


#7

Judging by the screenshot, you are using the Windows version. Unfortunately, at the moment the extra features that need sign in (the live coding / build tab) are only supported on the Mac version. We hope to release Windows support soon!


#8

Sorry to interfere the thread, just wanted to know if I said something wrong:
@timur The “New GUI Component” is not available on windows? I will have to compile my projects for windows soon, coming from mac ATM.


#9

The “New GUI Component” stuff is entirely cross-platform and dates back to the old Introjucer (and before!). It has nothing to do with the new compiler engine.


#10

@daniel I tried as you said. But it is still not working. I am using it on windows. And as @timur said it is still not available on windows.

Thanks for your answers.

I think I need to wait till Windows version is updated.


#11

No, that’s not what Timur said!

You’re getting confused between the GUI component editor and the live coding engine. The GUI component editor is completely open-source and cross-platform. daniel’s reply to your original post explains correctly what you need to do.


#12

I understood it now. Live coding is still not available on Windows platform.

But Add New GUI Component thing is also disabled for me.

How to enable it?


#13

Daniel’s original reply explains very clearly what to do. Not sure what else you want us to tell you!


#15

Can you get this menu by rightclick on “Sources”?

Select HERE “Add New GUI Component” and follow the wizard. This creates a cpp and a header file, which is the component you can populate with the greyed out menu you were looking at. It will get activated, when you select the new created cpp file.

You cannot add components to arbitrary CPP classes, only to a Component created with the “Add New GUI-Component” wizard.

HTH


#16

Yes.

i can get this menu by right-clicking on sources.

Thanks for your explanatory answer.


#17

I get the “Sign In” window as well, and I don’t have the live coding option… Also, the “recent files” menu is always empty.
Edit: ok, this is probably because I’m on a Mac and I COULD theoretically sign in and use live coding for a month, right?


#18

Hi, I just Installed it on a Mac using Mavericks and I thought it would work, but the sign in screen appeared, and I really couldn’t click on the Sign In button. It just didn’t work. So I read this thread, and as I was trying to solve it by myself, and suddenly found the dumbest solution. It didn’t work with the mouse, but only worked with the keyboard. So I wrote my email and password, and instead of trying to click the button, I just pressed the enter key immediately. It was simple, and made my life easier, and my heart happier. I hope it works for anybody else.


#19

I am a beginner. I was able to log into the Projucer from Juce 5.3.
But I don’t see the “Add New GUI Component…” option as in the screenshots above when right clicking any cpp file in the file explorer and all the menu entries under “GUI Editor” are greyed out.
Also, the “Live Coding” seems to be disabled, as the “Enable Compilation” option has no effect either.
I am on Ubuntu 16.04. Any further guidance would be appreciated, I am not sure what I am doing wrong.

EDIT:
Never mind about the “Add New GUI Component…” entry. I figured that it only shows when right clicking on the “Source” directory icon instead of a cpp file.

I am still wondering about compiling from the Projucer app however, it does not let me. Maybe it’s not enabled in the one month trial period any more?


#20

It is included in the trial, but IIRC it is not yet available on Linux? I tried the forum search, last statement I found was from April 2016:

The website for Projucer doesn’t mention linux at all… pity…


#21

Yes it actually says something like “Linux support for live coding in Projucer is in progress, visit website for updates” in the GUI, so my question was sort of redundant, apologies.