RTAS introjucer Project does not compile


#1

Hi all,

I'm trying to compile a pluigin fx in RTAS for windows and I do not manage to do it.

To simplify the issue, I've start from scratch. I've created a brand new audio plugin project from introjucer last version (with Juce 3.1.1) and opened in VS2012. It does not compile with the following error:


1>c:\program files (x86)\microsoft visual studio 11.0\vc\include\stdint.h(10): error C2371: 'int32_t' : redefinition; different basic types
1>          c:\projects\00 sdks\pt_80_sdk\alturaports\alturasource\ppc_h\cgbase.h(58) : see declaration of 'int32_t'

There are three similar errors.

I've tried PT_80 & PT_90 SDKs with same result.

I've tried to follow the include output file and I am ver lost in Protools includes maze.

Any clue? Any alternative?

If not, does anybody know what is the latest introjucer/jucer/VStudio working combination?

 

Thanks in advance

Gabriel


#2

I have no such issues with VS2010...


#3

Do you mind to say what Jucer/Introjucer version you use?


#4

The latest, of course... cool


#5

Ok thank you! Very helpful indeed!
Gabriel