What version of RTAS does the Introjucer work with?


#1

I was using the Introjucer to set-up a project the last few days, and I kept getting an error when compiling the RTAS code using the SDK from ProTools 9 about XCode not being able to find the file: EntrypointMacros.h

I made one of the include directories recursive and that fixed the problem, but I was wondering what version of RTAS the Introjucer is set-up to work with. I also tried using the ProTools 8 SDK with the bug fix patch but I had the same error.

The Introjucer is really awesome by the way! I’ve been using Juce for a while now, and I never realized what it does… Perhaps, another name for the app might make that a bit more self-evident…


#2

The last RTAS SDK I’ve used was 8.0, I never moved up to 9.0.

I kind of like the “introjucer” name! Couldn’t think of anything better, anyway!


#3

Well, if you did want to make the Introjucer work out of the box with the later RTAS SDK’s, I think you’d only have to set this directory as a recursively searched directory “AlturaPorts/TDMPlugIns/common” just as you had done for a few other directories…


#4

Ok, thanks, I’ll do that!