[solved] Introjucer rejects custom juce module


#1

Hi,

I implemented a module, which was up to now only one source file, so I could manage to load it in the introjucer. Now for better readibility I turned it into several files and adapted the juce_module_info to match exactly the examples I get from the original juce modules, including using .mm wrappers for xcode.

Introjucer says: "Cannot find this module at the specified path!"

The complete source files are in github in a feature branch: https://github.com/audiokinematics/juceLayouts/tree/ValueTree (saving and loading of dynamic layouts).

All projects compile, if I add the source files manually into the xcode project.

It would be great, if somebody could have a look, if I or the Introjucer is doing something wrong...

Thanks,

Daniel


#2

Check this out: http://www.juce.com/forum/topic/custom-module-relative-path-problems

If you want an example, I fixed up dRowAudio and its module manifest: https://github.com/jrlanglois/drowaudio/tree/master/module/drowaudio


#3

Thanks, I was looking into it. The project manifest is already in the second evoultion stage, so I had it working before. But thanks for the pointers, it's always good to get as many references as possible.

Switching the Introjucer into the debug mode revealed, that the json of the juce_module_info was broken. I added a second header simply with a comma, but it would need to be an array then.

Turning the headers value into an array (i.e. add square brackets around) made the Introjucer load the module again. But now the generated header has not names, but #include "modules/juce_ak_layout/[Array]", which cannot work.

Seems that only one include per module is allowed.

- exporting - building - check, it works, if there is only one include in the json.


#4

Hi, I’ve tried using your fork of drowaudio, but projucer doesn’t seem to want to accept it as a valid juce module in any way? (i.e. if I try to add the directly or any of the subdirectories that seem plausible by right-clicking Modules - Add a module from a specified folder, or if I try to draw the juce_module_info file onto that Modules list in projucer as your documentation suggests).

I was also trying to work-out what specific commit(s) were where you actually made to ‘fix-up’ of dRowAudio to fix it / make it compatible the newer projucer I’m guessing? The best I could guess that it was perhaps the “Moved files around” commit?


#5

I’ve not had a chance to update it to the latest juce module format yet.
In order to do that I also need to change some of the FFT handling on Mac which basically involves refactoring that whole class. I just won’t have time to do that soon I’m afraid.


#6

If you check the commit dates on my fork, you’ll notice that I haven’t been actively keeping up. It’s simply too time consuming to bother - but you’re certainly welcome to pick up where I left off!

As for how I fixed it - something about moving the module manifests solved the problem, but I don’t quite remember anymore.