Splash screen appearing on every window open


Whilst testing & debugging, the ‘Made with Juce’ corner splash screen appears every time I open a new window. Seeing as my app makes heavy use of multiple windows, this happens very frequently. Is there a way to stop this or is it a bug?

Thank you.

The expected behaviour is that the splash screen is displayed in every window created until the splash screen has been displayed for two seconds. Any window created after the splash screen has been displayed should not trigger and additional splash screen.

Is this consistent with what you are seeing?

Ah, I thought the splash would only be on the main screen for 2 seconds, it’s appearing in all screens for two seconds. Is it possible to amend so that it only appears on the main screen?

I’m afraid not; there’s no real concept of a “main” screen in JUCE.

Is it possible to have it appear on only one screen then, it’s quite a lot of Splash! I wouldn’t mind for users as it’ll only happen on startup, but when you’re testing it’s quite disruptive.

Then simply disable it while testing, and make sure you enable it again before you release.

You can do this via the Projucer by compiling the Projucer yourself in “GPL mode”: change the JUCER_ENABLE_GPL_MODE precompiler variable in the Projucer’s AppConfig.h and build it yourself. You’ll then have the option to disable the splash screen.

The other, easier, solution is to change the JUCE_DISPLAY_SPLASH_SCREEN variable to 0 in your application’s AppConfig.h.

Thank you t0m!