Strange stuff going on after leaving code untouched

I have left my all working files on a hard drive for a few months while I get the PCB’s laid out for the new prototype and when I came back to my code I got 20 errors in my build. These errors seem to be with the juce framework files which throws me off. The error messages are as follows:

Cannot define or redeclare ‘~ActionBroadcaster’ here because namespace ‘juce’ does not enclose namespace ‘ActionBroadcaster’ ( a bunch of times same error )

No member named ‘juce_assert_noreturn’ in namespace ‘juce::juce’; did you mean simply ‘juce_assert_noreturn’?

No member named ‘juce_isRunningUnderDebugger’ in namespace ‘juce::juce’; did you mean simply ‘juce_isRunningUnderDebugger’?

No member named ‘logAssertion’ in namespace ‘juce::juce’; did you mean simply ‘logAssertion’?

No member named ‘MessageManager’ in namespace ‘juce::juce’; did you mean simply ‘MessageManager’?

These errors make no sense to me? What could be going on do you think? Muchas gracias


1 Like

What IDE are you using? I was seeing something similar a few days ago with vscode. Only fix I found was to discard all my local changes and start from scratch.

1 Like

On Xcode I’ve occasionally had luck finding the folder for the project in
~/Library/Developer/Xcode/DerivedData/ and deleting it

Hey thanks for the heads guys. The only way I got to build again was to go back to V6.06, replace the stuff that changed for the upgrade and whala. I was back on but its annoying to have to peddle backwards. Im using Xcode. tried deleting derived data. Gave me back a massive chunk of my HD but that was all. I’m still trying to work it out. Will continue on 6.06 for now. Maybe it was a mac update?

just for clarity, your post indicates nothing changed, but this follow up seems to indicate that you changed versions of JUCE? If I have misunderstood, I apologize. If you had updated your version of JUCE, it is not unreasonable that you need to update your code.

I backdated my version since the post.

I forgot to mention actually I am getting issues with a Jassert as follows. Its the major 11 line that’s the issue. Sorry im not trained I normally have programmers. Can any body shed light on this. Im running Monterey with Xcode version 13.4.1 and juce 6.06. Here is the jassert. the second one on the 11os.

ystemStats::OperatingSystemType SystemStats::getOperatingSystemType()
return iOS;
StringArray parts;
parts.addTokens (getOSXVersion(), “.”, StringRef());

const auto major = parts[0].getIntValue();
const auto minor = parts[1].getIntValue();

if (major == 10)
    jassert (minor > 2);
    return (OperatingSystemType) (minor + MacOSX_10_7 - 7);

jassert (major == 11);
return MacOS_11;