Windows default VST3 location

Hi, does this actually work for anyone?

Programfiles is locked down on Windows and even as admin shouldn’t be able to copy to this location? This step always fails for me unless I changes this to somewhere else.


I can compile into:–
C:\Program Files\Common Files\VST3
C:\Program Files\Steinberg\vstplugins
You really need to change your permissions on the location.
Unfortunately you can’t really change the location in projucer if you want 32 and 64 bit in different places.

I can’t change permissions on that location. Strange

Are you using Windows 10?


I personally use a post script batch file to copy my files to my installer and run my installer which has elevated permissions… but have you tried setting Visual Studio to run as Admin?



no, haven’t tried that - but it’s a good idea - i just don’t want loads of admin files written around… need to figure out why I can’t add write perms to the common program files folder I think.