JUCE 4.2's AU v2: rez & compatibility


#1

Just got the new 4.2 and built the Demo Plugin as AU v2. While it passes auval, it won’t show up in Ableton Live 9 (which the 4.1 version did).

I also noted that juce_AU_Resources.r has been deleted. Does this mean carbon-style hosts are no longer supported by JUCE plugins? Because there are lots of them…


Ableton on Yosemite problems
4.2.1 and RTAS on OSX: -7400 error
Auval - trouble parsing Info.plist's AudioComponents
#2

it’s a total mess. au v2 don’t show up in cubase 8 here anymore and basic support of multibus is practically broken in logic and cubase hosts, making my plugs unusable… any chance to revert the plugin code to a usable state please? i’m getting tired of trial and error because your guide doesn’t work and projucer is actually broken (i’m now unable to select universal binary on osx anymore)


#3

Huh? As far as I know Cubase does not support AudioUnits at all, only VST. Are you sure the mess is not on your side?


#4

Hi timur, I would appreciate it if you could respond to my original post about Rez. In my view, making commercial audio units without it is a no-go, so for now I’ll need to stay on Juce 4.1, which is a shame.


#5

OK, sorry to hear that something broke with the Rez stuff. Could you perhaps send me a project that doesn’t work, or even better, tell me a way to reproduce the problem with some existing project like the juce demo plugin? This would be very helpful in tracking down the problem, as unfortunately out of the top of my head I don’t know what’s going on there…


#6

Ok, here’s the breakdown:

  • Build the Juce Demo Plugin as AU from the latest tip
  • Try to load it in (e.g.) Ableton Live

For me it doesn’t work and I’m pretty sure it’s because the Rez stuff is not there. Those resources now only exist as BinaryData in the Projucer – I assume the idea was to insert it into plugin projects somehow? But if so it’s not done yet.


#7

OK, thanks. Which flavour are you trying to load in Ableton? The AU or the VST?
Edit: sorry should have read your post more carefully. It’s about the AU. Testing it now!


#8

The VST works, but the AU doesn’t even show up in the list. Looking at the log from Ableton, it doesn’t even manage to locate the dylib.


#9

well yeah i explained badly, au v2 is not showing up anymore in any host.
it could be my culprit, will check that but upgrading juce was a bad idea.


#10

OK guys, really sorry for that, we’ll fix the AUv2 loading asap!


#11

So, I just tried to reproduce the problem, and I can’t.

  • Checked out clean repo of newest JUCE 4.2 tip
  • Compiled the plugin demo (AU target only)
  • Loads in Logic Pro X and also in Ableton Live 9 without problems!

I noticed that in Ableton you need to make sure AU plugins are enabled in the prefs, click “Re-scan”, and then also wait a minute or so until it actually shows up in the list.

About the Rez stuff: yes, the juce_AU_Resources.r file is not there anymore. And yes, afaik Carbon hosts are not supported anymore. But are there actually really any of them left??? (if so, which ones?) Live 9 is not a Carbon host (and it works fine there), neither is Logic. Cubase doesn’t support AU in the first place.


#12

That is weird! For me it’s a no-show. But I’m still on Live 9.1, maybe I should upgrade.

I still think you should at least make the rez stuff an option in Projucer. Backwards compatibility is not a bad thing…


#13

Yes I just tried it and you’re right, it does not show in Live 9.1. It does however show if you just upgrade to the current version of Live (9.6) which is free :slight_smile: so you should just do that.

Is there otherwise any major host app which is incompatible with the current (non-rez) version?


#14

But live 9.2+ does not run under 10.6 or xp :grin:


#15

I can of course do that, I’m more worried about my (future) customers & users…

Are there any seasoned developers around who can paint a picture of current AU hosts?


#16

Less compatibility is bad news. One of the nice thing of using Juce is not having to worry so much about iterations of OS X with the ever changing AU standard. Juce currently still supports 10.6.8 and being able to build the older carbon form of AUs should be part of that. Current AU hosts do not matter so much if a good number of audio people tend to update their OSes and hosts as late as possible (the never change a winning… bunch). It would be more reasonable to look at hosts running on the OS versions the framework supports.

As it stands this means the 9.2 update brings AUv3 support which is nice to have, but totally optional for now at the cost of breaking backwards compatibility with older versions of hosts as well as compatibility with some hosts that no longer will be updated but still are used.

Please bring back Carbon host compatibility if at all possible.


#17

This is bad news and prevent me from updating Juce. Lots of people are still on Live 9.1. Are other DAWs also affected? And what about Live 8?


#18

So… apparently the AU_Resources.r thing was removed accidentally rather than intentionally. We are going to bring it back. This will hopefully restore compatibility with Live 9.1. Please be patient, we consider this a high priority bug and will fix it as soon as possible.


#19

OK, I have fixed this now. Compatibility with carbon hosts should now be restored.

Basically, the new JUCE module format broke compiling the carbon resources with Rez, and it needed some modifications to persuade it to work again.

Please update to the newest tip and re-Introjuce re-Projuce your plug-in.

Hopefully now everyone can use JUCE 4.2 without further compatibility issues!


#20

This is still not working for me … JucePluginDemo AU won’t show up in Live 9.1 as of today’s tip (4.2.1). Did anyone else confirm that carbon works again?

Even worse, now the vst plugin doesn’t show up in the Live 64-bit, only in 32-bit, although it’s a universal binary (confirmed with otool). Strange!