Running Plugin in a DAW


I am trying to compile a VST3 library and use it in my DAW, I have tried loading it in Reason and FL Studio but it won’t show up in the list.

I read online in some old conflicting forum posts on different sources that quote needing a license to use them in a DAW, is this true? if so which license do I need?

Thank you!

It’s not a license issue.

Is the plugin copied to the same location where your other VST3 plugins are on the system? The hosts of course won’t be able to find a plugin from somewhere else, like your Juce project build folder.

1 Like

I added the Release/…/VST3 and Debug/…/VST3 directories to both DAW’s as search locations for the VST’s

I also create a new blank project and built it with just the template Hello World message and it also does not find it.

Do I need to adjust something from the Projucer app in the projects settings to get it running maybe?

You probably shouldn’t be adding your build folders into the host’s plugin paths. You should rather copy the built plugin binary to the recommended system location. (There’s an option in Projucer to make that happen automatically.)

Could there be a CPU architecture issue? Are you building a 64 bit plugin and testing in a 64 bit host?

Have you confirmed the .vst3 binary really has been built?

What operating system are you on? What are you using to build the project?

Does Reason actually even support VST3 at the moment? It looks like it doesn’t, so that would explain the plugin not appearing in Reason.

1 Like

Still no working

  • I enabled the copy functionality into my main VST3 plugin directory, now and tried.
  • Yes, all is in 64-Bit
  • Yes, the vst3 has been built, and it copied over
  • Windows 10, Visual Studio 2017 Community Edition
  • Yep confirmed reason does not like VST3. But my main DAW FL Studio does support VST3

I’m installing Cubase to test it out in that daw also

So! A couple of hours later… Success!

Cubase simply allowed me to double click on the plugin and open it, but that’s no fun :stuck_out_tongue_winking_eye:

The Fix was simple
FL Studio likes VST3 plugin to be in a specific folder for auto detection, “C:\Program Files\Common Files\VST3” but Visual Studio did not have permission to copy the file there.

I gave it permission et voila, it worked like a charm and it also allows me to debug it.

Thanks @Xenakios for the help!

1 Like

Reason does not work with VST3, only VST2