Tutorial plugin not working on windows


#1

Hi!
I followed the tutorials https://www.juce.com/doc/tutorial_create_projucer_basic_plugin and https://www.juce.com/doc/tutorial_code_basic_plugin. I’m working on windows, with visual studio 2015 and Ableton Live 9 Suite.
Today, after building the plugin and copying it to the plugins folder, Live doesn’t saw it.
Yesterday, Live treat it as an audio plugin, with audio input. I tried to check the “Plugin is a midi effect” box, but it’s still not working.:rage: Ideas?
Lenovo b590
Thanks
P.S. Sorry for the bad English, but I’m a young italian boy.:slight_smile:


#2

Maybe you need to update/refresh/rebuild Live’s plugin database/cache?


#3

I tried (options-preferences-file folder-rescan). It’s still not working.


#4

Maybe you have introduced a bug in the plugin that makes it crash during the scan. It is possible Live has a way to silently survive such crashes itself, for example by doing the plugin scan in a separate process. (Often the host will crash with the plugin, though.)

Have you tried other hosts besides Live?


#5

In both Ubuntu and windows, when I build for x64, the plugin host demo gives me an error.
When I build for i386, the plugin host works with my plugin. If i check “plugin is a midi plugin”, the plugin has only one red input and output. I’m thinking that Live is the problem.